Strona 1 z 1

Problem z formatem ESSI

PostNapisane: lut 01, 2019 14:15
przez majcher
Witam,
Mam mały problem z kodem ESSI wygenrowanym w programie NC Polaris. Wszystko pięknie ładnie tylko jest problem z łukami i otworami. Badanym elementem był kwadrat 300 na 300 z jednym zaokrąglonym wierzchołkiem na R100, tak jak w załączniku. Nie wiem co jest przyczyną takiego zachowania. Czytałem na jakimś forum, że w kod ESSI "luk ma znacznik, zaleznie czy jest łukiem dodatnim (tworzonym jak w układzie kartezjańskim - odwrotnie do wskazówek zegara), czy jest na odwrót"
Może ktoś zna odpowiedź na te pytanie. Może trzeba zmienić coś w postprocesorze. Załączam dodatkowo wygenrenowany kod na kwadrat 300x300 z łukiem:

3
rysunek2
4
3
GABARYT=300*300
GRUB=
MAT=
POCZ.UST.PAL.=
02-01-2019
4
5
-4-4
6
29
7
+4+4
+00+3000
+2000+00
+1000-1000+2000+2000-
+00-2000
-3000+00
-4-4
8
38
0
63
64
%


Re: Problem z formatem ESSI

PostNapisane: lut 05, 2019 09:25
przez Da_Vido
Witam.
Zgadza się, że inaczej kreślimy łuk zgodnie ze wskazówkami zegara a inaczej przy kierunku przeciwnym. W załączonym kodzie masz podane błędnie parametry kreślące poszukiwany łuk. Podsyłam kod, który kreśli kształt jaki chcesz uzyskać. Znajdź różnice ze swoim ;) Tak samo pewnie, jak zauważyłeś, błędnie program generuje otwory.

3
rysunek2
4
3
GABARYT=300*300
GRUB=
MAT=
POCZ.UST.PAL.=
02-01-2019
4
5
-4-4
6
29
7
+4+4
+00+3000
+2000+00
+1000-1000+-1000-
+00-2000
-3000+00
-4-4
8
38
0
63
64
%

Re: Problem z formatem ESSI

PostNapisane: lut 05, 2019 10:51
przez majcher
To to ja wiem, że w podanym kodzie są błędnie podane parametry kreślące. Kwestia jest tego typu,dlaczego tak się dzieje.
Sądzę, że cos jest nie tak z posprocesorem tylko co.

Re: Problem z formatem ESSI

PostNapisane: lut 08, 2019 09:58
przez Da_Vido
Pokaż jak wygląda postprocesor to może coś uda się poprawić, by działało dobrze.

Re: Problem z formatem ESSI

PostNapisane: lut 08, 2019 14:25
przez majcher
Podaj maila to ci wyśle na pocztę